Chaos Mind getting into order

problema no Apache2 & Perl

Posted on: 2007/04/16

Tenho o ocsinventory a correr aqui no trabalho e fiz actualização do servidor para debian etch. O apache2 já não arrancava depois do reboot. No /var/log/apache2/error.log:

[Mon Apr 16 18:46:16 2007] [error] Can’t locate Apache/compat.pm in @INC …

Nada que não se resolva:

# apt-get remove libapache2-mod-perl2
# apt-get install libapache2-mod-perl2

Depois começou a dar uns erros de configuração:

Starting web server (apache2)…Syntax error on line 16 of /etc/apache2/conf.d/ocsinventory.conf:
Invalid command ‘PerlSetEnv’, perhaps misspelled or defined by a module not included in the server configuration

Parece que o perl não está activo:

 # a2enmod perl

Ok, agora iniciar o apache2 dá o erro:

[Mon Apr 16 19:10:04 2007] [error] Can’t load Perl module Apache::DBI …

É por falta o libapache-dbi-perl:

# apt-get install libapache-dbi-perl

E voltei ao erro inicial… lindo!! Tenho de ver melhor isto!

Deixe uma Resposta

Please log in using one of these methods to post your comment:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s

%d bloggers like this: